plantage sur "retour arrière"

Par ici pour les partages d'expériences d'utilisation de Dmaths !
rbaudoin
Utilisateur
Utilisateur
Messages : 18
Inscription : lun. nov. 27, 2006 18:51 pm

plantage sur "retour arrière"

Message non lupar rbaudoin » sam. avr. 16, 2011 8:19 am

Bonjour,

depuis la dernière mise à jour de OpenOffice, j'ai un plantage à chaque fois que je veux supprimer une formule dmaths. Openoffice se ferme et il faut réinstaller Dmaths après la récupération du fichier par OOo.
J'utilise Mac OS X 10.6.7, OOo 3.3.0 (build 9567) et Dmaths 3.4.0.1

Quelqu'un connait-il ce problème ?
Amicalement
René Baudoin

charlysalmon
Confirmé
Confirmé
Messages : 46
Inscription : jeu. sept. 13, 2007 21:28 pm
Localisation : Bruxelles

Re: plantage sur "retour arrière"

Message non lupar charlysalmon » mer. avr. 27, 2011 23:24 pm

Bonjour,
Le bug est du côté de Open Office, mais Didier à trouver une solution, voici son message du 23 avril:
Bonjour à tous,

Bonne nouvelle : je pense avoir trouvé une explication pour le bug
repéré sous certaines configurations (MacOsX et Ubuntu).

Cela provient d'un changement dans la nomenclature de l'API : les
propriétés d'une formule ne sont plus stockées dans la propriété
embeddedobject mais dans model.

J'ai donc fait un copier-coller pour changer le premier terme en le second.
Les tests effectués sont concluants.

A noter toutefois que ce nouveau code est parfaitement opérationnel pour
les versions 3.4 beta de LibreO comme de OOo.

La version de Dmaths mise en ligne est la 3.4.0.5
www.dmaths.org/adons/DmathsAddon.oxt

Si votre configuration actuelle fonctionne ne changer rien.

Si vous le souhaitez, vous pouvez installer LibreO 3.4 beta2 ou OOo 3.4
beta puis mettre à jour votre Dmaths.

Si votre configuration actuelle ne fonctionne pas vous devez mettre à
jour Dmaths puis :
- soit conserver une version 3.3 et alors utiliser le Dispatcher (voir
options de Dmaths),
- soit installer une version beta 3.4

A noter que les versions 3.4 bénéficient de l'alignement automatique des
formules que nous attendons depuis plusieurs années (la fameuse issue 972).

Merci pour vos retours d'expérience.

Pour votre information, les moyens du club dmaths m'ont permis de faire
des tests avec Linux, Windows et Mac : une bonne raison d'adhérer au
club Dmaths.

Bon week-end.


Charly

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » lun. août 15, 2011 13:50 pm

Bonjour,

Sous Ubuntu 11.04, LibreOffice 3.3, Dmaths 3.4, j'ai toujours le problème de plantage avec la touche d'effacement. J'ai beau cocher la case "Utilisation du dispatcher" dans les options, ça n'a presque aucun effet. Je dis presque, parce qu'il y a une petite différence: avec la case cochée, si j'appuie sur effacer il ne se passe rien, et si j'appuie une deuxième fois ça plante...

Est-ce qu'il y a une solution?

Merci!

charlysalmon
Confirmé
Confirmé
Messages : 46
Inscription : jeu. sept. 13, 2007 21:28 pm
Localisation : Bruxelles

Re: plantage sur "retour arrière"

Message non lupar charlysalmon » mar. août 16, 2011 9:46 am

Bonjour,
lebendre a écrit :Bonjour,

Sous Ubuntu 11.04, LibreOffice 3.3, Dmaths 3.4, j'ai toujours le problème de plantage avec la touche d'effacement. J'ai beau cocher la case "Utilisation du dispatcher" dans les options, ça n'a presque aucun effet. Je dis presque, parce qu'il y a une petite différence: avec la case cochée, si j'appuie sur effacer il ne se passe rien, et si j'appuie une deuxième fois ça plante...

Est-ce qu'il y a une solution?

Merci!

La seule solution existante sous Ubuntu 11.04 est la désinstallation complète de la version de LibreOffice proposée par les dépôts ubuntu et son remplacement par la version officielle 3.4.2.

Un bon descriptif de la méthode à suivre se trouve ici
cela semble assez long mais c'est très bien expliqué et facile à réaliser

Une fois cette installation faite, tout fonctionne normalement (chez moi :) )

Charly

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » mar. août 16, 2011 20:38 pm

Merci pour le lien!

Est-ce qu'il y a un espoir pour que ça fonctionne dans une prochaine version de LibreOffice? (ou de Dmaths)

charlysalmon
Confirmé
Confirmé
Messages : 46
Inscription : jeu. sept. 13, 2007 21:28 pm
Localisation : Bruxelles

Re: plantage sur "retour arrière"

Message non lupar charlysalmon » mar. août 16, 2011 21:54 pm

Bonsoir,

en fait cela fonctionne maintenant dans LibreOffice 3.4.2 et avec la version 3.4.1.1 de Dmaths (Chez moi sous XP2, Vista, Seven et Ubuntu 11.04)
Sous Ubuntu, si on souhaite conserver la version fournie dans les dépôts, il faudra sans doute patienter jusqu'à la sortie de Ubuntu 11.10 pour voir apparaître LibreOffice 3.4.xx dans ses dépôts...

A+

Charly
Dernière édition par charlysalmon le mer. août 17, 2011 21:34 pm, édité 1 fois.

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » mer. août 17, 2011 20:23 pm

Si j'installe libreoffice 3.4.2 via un deb, c'est possible que ça fonctionne? Faut-il que je désinstalle d'abord la version installée via le gestionnaire de paquets?

charlysalmon
Confirmé
Confirmé
Messages : 46
Inscription : jeu. sept. 13, 2007 21:28 pm
Localisation : Bruxelles

Re: plantage sur "retour arrière"

Message non lupar charlysalmon » mer. août 17, 2011 21:32 pm

Bonsoir,
lebendre a écrit :Si j'installe libreoffice 3.4.2 via un deb, c'est possible que ça fonctionne? Faut-il que je désinstalle d'abord la version installée via le gestionnaire de paquets?

Je renvoie au lien déjà poster plus haut :
extrait :
Vous avez une version LibreOffice installée par les paquets d'Ubuntu : la 3.3.2 ou la 3.3.0
Il faut la désinstaller totalement pour éviter tout conflit
soit par la commande dans un terminal

sudo apt-get remove libreoffice*

soit par un programme de Gestionnaire de paquets
plus long que cette commande mais qui permet de sélectionner soi-même les paquets
et qui permettra également de vérifier si tous les paquets ont bien été désactivés par la commande ci-dessus.
Synaptic ...


La suite au paragraphe III du tuto

Pour l'installation Points II, IV et V du même tuto

Manifestement les deux versions de LibreOffice ne font pas bon ménage.

J'ai déjà fait ces manips plusieurs fois : à chaque mise à jour de Ubuntu, je supprime la version de LO (avant Ooo)des paquets et la remplace par la version offcielle... il suffit vraiment de suivre pas à pas ce tuto et tout fonctionne sans problème. Le plus rapide est de copier coller les commandes dans un terminal.
Pour le téléchargement de LO, le site détecte sans problème quelle version tu dois télécharger

Si tu ne supprime pas ton profil, la nouvelle version le reconnait et il ne faut même pas réinstaller Dmaths

A+
Charly

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » jeu. août 18, 2011 19:21 pm

Merci beaucoup pour ces précisions, tout fonctionne avec la version 3.4 officielle! Youpi! :D

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » ven. sept. 02, 2011 11:58 am

En utilisant Dmaths dans mon école sous MacOS, Openoffice 3.3, l'erreur est là (normal...), mais le Dispatcher ne fonctionne pas. OOo plante si j'efface une formule que je viens de créer. Est-ce qu'il y a une autre solution que l'installation de LibreOffice 3.4?

Merci!

Avatar de l’utilisateur
didier
Site Admin
Site Admin
Messages : 446
Inscription : ven. mars 31, 2006 17:54 pm
Localisation : France 74
Contact :

Re: plantage sur "retour arrière"

Message non lupar didier » dim. sept. 04, 2011 17:52 pm

Bonjour,

mais le Dispatcher ne fonctionne pas.


Avez-vous sélectionné cette option dans les options de Dmaths ?

Cordialement.
Didier Dorange-Pattoret

Soutenez le projet Dmaths : rejoignez le club ou faites adhérer votre établissement !
La page pour les établissements

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » lun. sept. 05, 2011 17:04 pm

Oui oui, j'ai bien sélectionné. Je vois une différence: avec le dispatcher, la touche "retour arrière" n'a pas d'effet à la première fois, mais plante à la seconde tentative...

lebendre
Newbie
Newbie
Messages : 9
Inscription : jeu. août 11, 2011 20:55 pm

Re: plantage sur "retour arrière"

Message non lupar lebendre » ven. sept. 09, 2011 9:45 am

Je fais remonter un poil le sujet...

Est-ce qu'en installant une version antérieure d'OpenOffice, ça pourrait fonctionner? Parce que j'ai prévu de présenter Dmaths à des collègues, et si ça marche pas, je vais pas faire le malin :P :oops:

Merci!

charlysalmon
Confirmé
Confirmé
Messages : 46
Inscription : jeu. sept. 13, 2007 21:28 pm
Localisation : Bruxelles

Re: plantage sur "retour arrière"

Message non lupar charlysalmon » sam. sept. 10, 2011 19:50 pm

lebendre a écrit :Je fais remonter un poil le sujet...

Est-ce qu'en installant une version antérieure d'OpenOffice, ça pourrait fonctionner? Parce que j'ai prévu de présenter Dmaths à des collègues, et si ça marche pas, je vais pas faire le malin :P :oops:

Merci!

Bonsoir,

c'est à tenter puisque le problème est apparu avec une mise à jour de OOo, une version antérieure à la 3.3 pourrait bien ne pas présenter le problème.

Charly

chaponinho
Newbie
Newbie
Messages : 1
Inscription : dim. sept. 11, 2011 14:56 pm

Re: plantage sur "retour arrière"

Message non lupar chaponinho » dim. sept. 11, 2011 17:22 pm

Bonjour,

Effectivement, installer uns ancienne version de Open Office résous le problème.

J'ai eu le même soucis sur Mac avec Open Office 3.3 et Dmaths 3.4. J'ai donc réinstallé Open Office 3.2.1 et Dmaths 3.4 et ça fonctionne.

En attendant que ça fonctionne avec Open Office 3.3 ;-)

A+,

Damien


Revenir vers « Version pour LibreOffice : Fonctionnement »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 5 invités